Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001492 [Cacti] Templates (Graph, Data, Host) major always 2009-06-28 12:43 2012-10-24 03:38
Reporter ccf View Status public  
Assigned To gandalf
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 0.8.7e Product Version 0.8.7d
  Target Version Product Build
Summary 0001492: RRDTool 1.3 series fonts
Description Since 1.3.1, RRDTool uses fontconfig, and accepts a font name rather than a specific file, however, this cannot be set using the "Visual" settings page, which will complain if the value given does not correspond to a real file on the filesystem, and thus won't use the font.
Steps To Reproduce
Additional Information The syntax for using the FreeMono font on a Debian clone under the 1.2 series was:

--font TITLE:12:/usr/share/fonts/truetype/freefont/FreeMono.ttf

As of the 1.3 series, this is now:

--font TITLE:12:FreeMono

However, entering "FreeMono" in any of the font fields returns the complaint
[ERROR: FILE NOT FOUND], and the value is ignored, resulting in RRDTool using the default font, which in my case is proportional rather than monospaced.

Suggested resolutions:
In the short term, disable the file check if RRDTool 1.3 is selected. In the longer term, validate against the output of "fc-list", not the contents of the filesystem.

Also, suggest detecting RRDTool version rather than asking the user for it. Running "rrdtool" with no parameters, the first thing it tells you is the version number.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004166)
TheWitness (developer)
2009-07-01 09:15

What is the Linux command to list all available fonts via fontconfig?
(0004167)
TheWitness (developer)
2009-07-01 09:16

Please see my prior note.

TheWitness
(0004169)
ccf (reporter)
2009-07-01 12:18

From the Additional Information field:
'... validate against the output of "fc-list", ...'

Font names are terminated by a colon, but otherwise there seems to be little limitation on what's allowed in a font name (entries on my system contain spaces, underscores, accented characters, and Hangul). Both names and styles may be single entries or comma-separated lists. Examples:

DejaVu Sans Mono:style=Book
DejaVu Sans Mono:style=Bold

#Pathological case
Bodoni MT,Bodoni MT Condensed:style=Condensed Bold Italic,Negreta cursiva,tučné kurzíva,fed kursiv,Fett Kursiv,Έντονα Πλάγια,Bold Italic,Negrita Cursiva,Lihavoitu Kursivoi,Gras Italique,Félkövér dőlt,Grassetto Corsivo,Vet Cursief,Halvfet Kursiv,Pogrubiona kursywa,Negrito Itálico,Полужирный Курсив,Tučná kurzíva,Fet Kursiv,Kalın İtalik,Krepko poševno,Lodi etzana
(0004344)
Clipper (reporter)
2009-09-16 06:51

I can work on a patch.

I think of using a new "fontcheck" method to replace the "filepath" method currently used. Basically that method will check the current RRDTool setting used and validate the font field content based on that.

* for <1.3 check the validity of the file path
* for >=1.3 check the font name using fc-match like this :

[code][cacti@cthulhu:~] (5) > fc-match "DejaVu Sans Mono"
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"[/code]
(Basically validate that fc-match returns one and single line only)

It will also need an additional setting for the location of fc-match binary.

That'll be my first patch for this project. Any advice on patch submitting ?

HTH
(0004359)
gandalf (developer)
2009-09-26 06:22

diff -Nabur
would be best.
Please remember to verify windows as well
(0004413)
gandalf (developer)
2009-10-03 16:46

SVN#5331 for 087e
SVN#5332 for 088
(0004428)
ccf (reporter)
2009-10-05 13:37

Claims "fixed in 0.8.7e", but that version was released months ago. "Fixed in" should be set to the stable release that features the fix.
(0004429)
TheWitness (developer)
2009-10-07 07:53

Is this really fixed Reinhard? Do we now have FontPath? Did not look. If so, have tony release a patch.
(0004496)
gandalf (developer)
2009-11-24 15:46
edited on: 2009-11-24 15:47

This was indeed fixed. I just verified it.
To ccf: we set "fixed in" to the base version were we (are going to) release the patch. So it is meant to be read as:
Fixed in 087e by applying the patch.
I only am not able to verify this for windows.

And I just saw, that the fix is not THAT good. It only works on rrdtool 1.3, not on 1.4 which is bad. I will have to rework.


- Issue History
Date Modified Username Field Change
2009-06-28 12:43 ccf New Issue
2009-07-01 09:15 TheWitness Note Added: 0004166
2009-07-01 09:16 TheWitness Note Added: 0004167
2009-07-01 09:16 TheWitness Status new => feedback
2009-07-01 12:18 ccf Note Added: 0004169
2009-09-16 06:51 Clipper Note Added: 0004344
2009-09-26 06:21 gandalf Status feedback => assigned
2009-09-26 06:21 gandalf Assigned To => gandalf
2009-09-26 06:22 gandalf Note Added: 0004359
2009-10-03 16:46 gandalf Note Added: 0004413
2009-10-03 16:46 gandalf Status assigned => resolved
2009-10-03 16:46 gandalf Fixed in Version => 0.8.7e
2009-10-03 16:46 gandalf Resolution open => fixed
2009-10-05 13:37 ccf Note Added: 0004428
2009-10-07 07:53 TheWitness Note Added: 0004429
2009-11-24 15:46 gandalf Note Added: 0004496
2009-11-24 15:47 gandalf Note Edited: 0004496
2010-03-08 16:26 dkowis Issue Monitored: dkowis
2010-05-20 04:23 bootc Issue Monitored: bootc
2012-10-24 03:38 Linegod Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker